Close

800.245.9540 mackin@mackin.com Help Chat Open Chat Closed Chat Busy

Dreamscape System Requirements

Print Topic

Dreamscape

Browsers:

  • Latest version of Internet Explorer, Firefox, Chrome, or Safari

Operating Systems:

  • Windows 7+
  • Mac OS X 10.7+
  • Ubuntu 10+
  • Linux OS 11+ (64-bit)

Bandwidth:

  • 1 Mbps or higher

Additional Requirements:

  • Latest version of Adobe Flash Player or HTML 5 compliant browser

Learn More about Dreamscape.

Related Articles

Comments are closed